Tela preta no Skype 2.2.0.35 Beta

Dica rápida para resolver o problema de tela preta no skype 2.2 beta + Ubuntu 11.04 32/64:

1. Abra o terminal e navegue até a pasta /usr/bin. Renomeie o executável do skype para skype.real:
#cd /usr/bin
#mv skype skype.real

2. Crie um arquivo chamado skype com o seguinte conteúdo:

Ubuntu 11.04 32 Bits
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype.real

Ubuntu 11.04 64 Bits
LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype.real

3. Dê permissão de escrita para o arquivo skype e pronto! Problema resolvido!
#chmod a+x skype

[Click here to english version]


Webcam Google Talk e Hangout no Ubuntu

Se a sua webcam não for detectada pelo plugin do google talk video ou do google hangout, possivelmente os passos abaixos resolverão seus problemas.
É preciso ter o plugin do google talk instalado. Se você não tem o plugin, veja como fazer isso, seguindo os seguintes passos:

1. Adicione o repositório do google talk com o comando
sh -c 'echo "deb http://dl.google.com/linux/talkplugin/deb/ stable main" >> /etc/apt/sources.list.d/google.list'

2. Instale a chave que valida o repositório com o comando
wget -q -O – https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add –

3. Instale o plugin com os comandos
apt-get update
apt-get install google-talkplugin

Com o plugin instalado, execute os comandos abaixo caso a webcam não seja detectada:

Ubuntu 11.04 32 Bits
#sudo apt-get install libv4l-0
#sudo mv /opt/google/talkplugin/GoogleTalkPlugin /opt/google/talkplugin/GoogleTalkPlugin.real
#echo '#!/bin/sh' | sudo tee /opt/google/talkplugin/GoogleTalkPlugin
#echo "LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /opt/google/talkplugin/GoogleTalkPlugin.real" | sudo tee -a /opt/google/talkplugin/GoogleTalkPlugin
#sudo chmod +x /opt/google/talkplugin/GoogleTalkPlugin

Ubuntu 11.04 64 Bits
#sudo apt-get install lib32v4l-0
#sudo mv /opt/google/talkplugin/GoogleTalkPlugin /opt/google/talkplugin/GoogleTalkPlugin.real
#echo '#!/bin/sh' | sudo tee /opt/google/talkplugin/GoogleTalkPlugin
#echo "LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so /opt/google/talkplugin/GoogleTalkPlugin.real" | sudo tee -a /opt/google/talkplugin/GoogleTalkPlugin
#sudo chmod +x /opt/google/talkplugin/GoogleTalkPlugin

Era isso!

[Click here to english version]


Ubuntu 11.04 32 + Kernel 3.0 RC 7